Register Register

Author Topic: The ancient Mechwarrior 2 Mercenaries... was there a hit detection bug?  (Read 552 times)

JureSimich

  • Recruit
  • *
  • Posts: 23
Hello. Silly, I know, but I figured I might as well ask here...

In the old Mechwarrior 2 Mercenaries game, the wossname special edition, was there a bug where the game failed to register weapon hits? Because I remember having to place MLas on separate locations or else game wouldn't register the hits, and AC 20s were right out.

I was just remembering how my weapon preferences changed from game to game...

Jayof9s

  • Captain
  • *
  • Posts: 2417
I don't recall a hitbox issue.

As for "placing medium lasers in separate locations" that, from what I vaguely remember nearly 30 years later, it only mattered for alpha-strikes. I.e. if you had 2 of the same weapon in the same arm it would give the heat from both but only fire one laser. I don't know for sure if it actually did less damage or not though, it may have just been visual. You could always chain shoot them though.

As for AC/20s, the only issue I remember was the ammo dependency. They all fired really fast, so the damage was good (especially the 20) but you'd be out of ammo in a few seconds.

JureSimich

  • Recruit
  • *
  • Posts: 23
ACs worked wonderfully in the original MW2, I just packed one or two and loaded up max ammo. For the Ghost bears, I couldn't resist the Arrow's range.

.Mercenaries, though... Zeus with the early ERLlas... later pulse lasers...Good days, but realy, my shots went through the enemies, I could swear... had to use lasers to keep up the barrage.

Still remember the Escape the Clans mission... and the early Ice one...

Damn, got all nostalgic now...

 

Register