Register Register

Author Topic: MekLab Won't Start, Windows 10  (Read 635 times)

Khyron42 Prime

  • Recruit
  • *
  • Posts: 2
MekLab Won't Start, Windows 10
« on: 09 February 2022, 04:01:57 »
MegaMek itself runs fine, and Java 11 (Temurin, specifically) installed; after double-clicking the .exe (either stable or development release, same result) a JAVA (now penguin) icon appears in the taskbar, with an empty window shown on mouseover for a moment. Clicking the application does nothing.

In Task Manager, the OpenJDK Platform Binary is running but not using any CPU.

dgorsman

  • Captain
  • *
  • Posts: 1749
Re: MekLab Won't Start, Windows 10
« Reply #1 on: 09 February 2022, 15:04:34 »
Could the window be offscreen?
Think about it.  It's what we do.
- The Society

Thunder LRMs: the gift that keeps on giving.  They're the glitter of the BattleTech universe.

Khyron42 Prime

  • Recruit
  • *
  • Posts: 2
Re: MekLab Won't Start, Windows 10
« Reply #2 on: 10 February 2022, 03:25:14 »
Could the window be offscreen?

Well hell, yes it is. Why in the crap is it doing that? I have to Rclick the mouseover window, click Move, then keyboard it onto the screen. Every time it starts!

Good thinking though, much appreciated.

dgorsman

  • Captain
  • *
  • Posts: 1749
Re: MekLab Won't Start, Windows 10
« Reply #3 on: 10 February 2022, 23:33:35 »
Cheers.  For what it's worth, I see this with professional engineering software as well (it's my job, so it's one of the first things I check).
Think about it.  It's what we do.
- The Society

Thunder LRMs: the gift that keeps on giving.  They're the glitter of the BattleTech universe.