Register Register

Author Topic: Weird Line Break Shenanigans  (Read 539 times)

pokefan548

  • Lieutenant
  • *
  • Posts: 1514
  • The Barracuda knows where it is, hence the -2 mod.
    • Poke's Aerospace Academy (Discord Server)
Weird Line Break Shenanigans
« on: 22 June 2022, 13:54:04 »
Been having issues where deleting a line break between paragraphs attempts to shrink the lower paragraph to 78% size. [size=78%]Also had issues with double-spacing paragraphs resulting in an extra line break.[/size]

[size=78%]Anyone else have any issues with this?[/size]

[size=78%](Leaving the message unedited because, incidentally, I decided to remove a line break, and lo and behold...)[/size]
Poke's Aerospace Academy
The best place to learn and discuss AeroTech.


BattleTech players: Throwing the baby out with the bathwater since 1984!
"Poke is just a figment of our imagination really." - Siam
"Poke isn't a real person, he's just an algorithm programmed by CGL to try and get people to try the aerospace rules." - Phantasm
"I want to plant the meat eating trees and the meat growing trees on the same planet! Watch that plant on plant violence!" - Sawtooth

Daryk

  • Lieutenant General
  • *
  • Posts: 29016
  • The Double Deuce II/II-σ
Re: Weird Line Break Shenanigans
« Reply #1 on: 22 June 2022, 19:10:58 »
Uhh... no? ???

Sartris

  • Codex Conditor
  • BattleTech Volunteer
  • Colonel
  • *
  • Posts: 17846
  • Useless and I didn't even get to be pretty
    • Master Unit List
Re: Weird Line Break Shenanigans
« Reply #2 on: 22 June 2022, 19:11:51 »
is this something that worked before?

idea weenie

  • Major
  • *
  • Posts: 4063
Re: Weird Line Break Shenanigans
« Reply #3 on: 23 June 2022, 04:09:51 »
What commands were you using to create these line breaks, or double-spacing paragraphs?  Were you attempting to type them directly into the reply block, or were you copying from another word processing program?  If typing directly, which of the buttons above your reply were pressed before you had the error.  If copying from another word processing program, it may be a case where you need to use a 'simpler' word processing program so extra tags from that program are not brought over.

Can you link us some of your posts that had the issue, so we can see for ourselves?  The first post in this thread just displays "size=78%" and "/size" (with brackets) instead of any other tags.

This is me testing font size using the drop-down list and changing the value from '12' to '19' manually.  It worked correctly.

[size=75%]This is me testing font size by manually editing the size tag to use percentages.  This one did not work.[/size]

You may need to use the 'Preformatted Text" button option (next to the left-align button) to make the text look how you prefer it.

worktroll

  • Ombudsman
  • Colonel
  • *
  • Posts: 24659
  • 504th "Gateway" Division
    • There are Monsters in my Sky!
Re: Weird Line Break Shenanigans
« Reply #4 on: 23 June 2022, 04:11:24 »
Looks like "size" only accepts font size as an argument, not percentages.

I've only ever used "size=5" or the like, never seen percentages work. May be a feature of SMF forums.
* No, FASA wasn't big on errata - ColBosch
* The Housebook series is from the 80's and is the foundation of Btech, the 80's heart wrapped in heavy metal that beats to this day - Sigma
* To sum it up: FASAnomics: By Cthulhu, for Cthulhu - Moonsword
* Because Battletech is a conspiracy by Habsburg & Bourbon pretenders - MadCapellan
* The Hellbringer is cool, either way. It's not cool because it's bad, it's cool because it's bad with balls - Nightsky
* It was a glorious time for people who felt that we didn't have enough Marauder variants - HABeas2, re "Empires Aflame"

pokefan548

  • Lieutenant
  • *
  • Posts: 1514
  • The Barracuda knows where it is, hence the -2 mod.
    • Poke's Aerospace Academy (Discord Server)
Re: Weird Line Break Shenanigans
« Reply #5 on: 23 June 2022, 08:50:30 »
Everything has been typed in the box here. No external programs.

Can you link us some of your posts that had the issue, so we can see for ourselves?  The first post in this thread just displays "size=78%" and "/size" (with brackets) instead of any other tags.
Unfortunately not, I've made a habit of quickly editing affected posts. That being said, this post will be an example of unintended triple-spacing.


I could have sworn everything worked correctly for the first week or so of active posting, but... I honestly can't be 100% sure. I've slept since then. I don't generally futz with the formatting buttons and dropdowns when I can help it, I'm an old BBCode grognard too used to just manually typing each tag. Curiously, the issue with deleting line breaks does shrink the text in the post/reply box as though I had selected a different size from the dropdown menu, and also seems to be, oddly enough, a fix for the triple-spacing issue (resetting the font size adds a (size=2)Lorem Ipsum(/size) tag to each paragraph, which I... suspect helps fix things? But said tags are only visible while editing afterwards.).


Also, these issues don't seem to appear when editing a post or reply, only creating one. Furthermore, these symptoms persist across multiple computers.

EDIT: Here's what my Look and Layout settings look like, as I suspect one of them may be the culprit. A lot of this, if memory serves, started up around the time I changed them (primarily to return to topic, as that's what I'm used to). That being said, I can't be certain.
« Last Edit: 23 June 2022, 09:58:58 by pokefan548 »
Poke's Aerospace Academy
The best place to learn and discuss AeroTech.


BattleTech players: Throwing the baby out with the bathwater since 1984!
"Poke is just a figment of our imagination really." - Siam
"Poke isn't a real person, he's just an algorithm programmed by CGL to try and get people to try the aerospace rules." - Phantasm
"I want to plant the meat eating trees and the meat growing trees on the same planet! Watch that plant on plant violence!" - Sawtooth

idea weenie

  • Major
  • *
  • Posts: 4063
Re: Weird Line Break Shenanigans
« Reply #6 on: 23 June 2022, 19:41:11 »
Everything has been typed in the box here. No external programs.
Unfortunately not, I've made a habit of quickly editing affected posts. That being said, this post will be an example of unintended triple-spacing.


I could have sworn everything worked correctly for the first week or so of active posting, but... I honestly can't be 100% sure. I've slept since then. I don't generally futz with the formatting buttons and dropdowns when I can help it, I'm an old BBCode grognard too used to just manually typing each tag. Curiously, the issue with deleting line breaks does shrink the text in the post/reply box as though I had selected a different size from the dropdown menu, and also seems to be, oddly enough, a fix for the triple-spacing issue (resetting the font size adds a (size=2)Lorem Ipsum(/size) tag to each paragraph, which I... suspect helps fix things? But said tags are only visible while editing afterwards.).


Also, these issues don't seem to appear when editing a post or reply, only creating one. Furthermore, these symptoms persist across multiple computers.

EDIT: Here's what my Look and Layout settings look like, as I suspect one of them may be the culprit. A lot of this, if memory serves, started up around the time I changed them (primarily to return to topic, as that's what I'm used to). That being said, I can't be certain.
The only difference between mine and yours was that I did not have the "Show WYSIWYG editor on post page by default" set to on.  I'm going to change mine to be on, and see if I can get a similar problem.  The first issue I can see is that you only see the final product, rather than the behind-the-scenes that goes on.  For example, your linked image is a hyperlink, rather than the "url=" and "/url" (but with brackets) that I would see.

If you get another post with this issue, can you link to that post in this thread, or just copy-paste the post so we can try to get a better idea?

The other option might be for you to unselect the "Show WYSIWYG editor on post page by default" so you have better control over your posts.

One idea might be using the "Preview" button so you can see what your post will look like before posting.  This combined with unselecting the WYSIWYG could help you see where the commands are causing issues.  Preview is one of the major features I use on this forum, and if someone looks at my forum activity they would see that I use the "Preview" option multiple times on each post, to make sure I get it right (and even then I fail sometimes).

I tried testing by making a large paragraph after the above sentence, then pressing the "Delete" key to bring the large paragraph up, but was unable to get the "size=78%".  The one thing I did notice is that the single line breaks I had in the text pane did not show up in the Preview.  I had to put double line breaks to separate the individual sentences and paragraphs above.

pokefan548

  • Lieutenant
  • *
  • Posts: 1514
  • The Barracuda knows where it is, hence the -2 mod.
    • Poke's Aerospace Academy (Discord Server)
Re: Weird Line Break Shenanigans
« Reply #7 on: 24 June 2022, 11:50:57 »
The WYSIWYG editor seems to have been the culprit. Not even sure why or when I turned it on, but we're all good now.

Many thanks for the help troubleshooting.
Poke's Aerospace Academy
The best place to learn and discuss AeroTech.


BattleTech players: Throwing the baby out with the bathwater since 1984!
"Poke is just a figment of our imagination really." - Siam
"Poke isn't a real person, he's just an algorithm programmed by CGL to try and get people to try the aerospace rules." - Phantasm
"I want to plant the meat eating trees and the meat growing trees on the same planet! Watch that plant on plant violence!" - Sawtooth

 

Register